User Tools

Site Tools


Sidebar

Unconstrained ordinations in JUICE+R

ordijuice:install

How to install:

Are you new to JUICE and R?

  1. Download and install the latest version of the JUICE program. To learn more about JUICE, visit JUICE website. Note that if you install JUICE for the first time, you need to manually update the program to the latest version (after installation, start JUICE, and in menu go to Help > Quick JUICE Update, and follow the automatic update procedure).
  2. Download and install R-project. To learn more about R, visit R-project website. You need to install R 2.11.0, and namely 32-bit version!1) (you can install this version directly from here).
  3. Import and open your data in JUICE (if you don't have any, download training data)
  4. in JUICE go to Analysis > Ordinations > R-PROJECT > DCA analysis and
    1. click on folder Script update,
    2. click on Associate R-project with JUICE and set up the path to Rgui.exe file (located usually in C:/Program Files (x86)/R/R-2.11.0/bin/Rgui.exe). Note that you need to associate it with Rgui.exe file, not R.exe file!
    3. click on Installation of R libraries to install necessary R packages (your computer needs to be connected to Internet). If all setting is done correctly, you should see the progress bar announcing installation of several R libraries.

Are you already working with JUICE and R?

  1. Update JUICE to version >= 7.0.25 (from Help JUICE menu or installing the new JUICE from website).
  2. Install an old R-project version 2.11.0, namely 32-bit version!2) (you can install this version from here).
  3. In JUICE go to Analysis > Ordinations > R-PROJECT > DCA analysis and click on Associate R-project with JUICE and set up the path to Rgui.exe file (located usually in C:/Program Files (x86)/R/R-2.11.0/bin/Rgui.exe). Note that you need to associate it with Rgui.exe file, not R.exe file!
  4. Make sure you have updated all required R packages (in JUICE, go to Analysis > Ordinations > R-PROJECT > DCA analysis > Script update and click on Installation of R libraries button. Your computer needs to be connected to internet!)
1)
This function is supported since R version 2.8 till 2.12, however, it's functionality is not guaranteed for all of these versions. Before we recommended to use version 2.9.0, but since recently (spring 2016) it's not possible to automatically install required R libraries for it. Newly only version 2.11.0, and only it's 32-bit version works well without problem with latest ordijuice library
2)
This function is supported since R version 2.8 till 2.12, however, it's functionality is not guaranteed for all of these versions. Before we recommended to use version 2.9.0, but since recently (spring 2016) it's not possible to automatically install required R libraries for it. Newly only version 2.11.0, and only it's 32-bit version works well without problem with latest ordijuice library
ordijuice/install.txt · Last modified: 2016/09/01 13:00 (external edit)